Обнаружена уязвимость в Android 4.4 KitKat

Сегодня Богдан Алеку довелось публично продемонстрировал на конференции DefCamp 2013 уязвимость в смартфонах семейства Nexus, которая может привести к перезагрузкам и потери связи. Богдан, работающий системным администратором, отметил, что уязвимость была обнаружена ещё на Nexus 4 с прошивкой Android 4.3. Он уведомил софтверного гиганта о найденной уязвимости, но видимо там не посчитали её критической, поэтому уязвимость осталась актуальной и на Android 4.4 KitKat.

Усугубляет проблему и тот факт, что воспользоваться данной уязвимостью может любой желающий без серьезных знаний в IT сфере. Вся суть сводиться к отправке Flash СМС, которое высылается с помощью специального сервиса или определенного формата сообщения (*Flash#текст). Сообщение доставляется беззвучно, отображаясь лишь на экране телефона. Оно не храниться в памяти и высылается как уведомление. Для того чтобы отправить в перезагрузку Nexus 5 достаточно нескольких подобных СМС сообщений. Уязвимость была подтверждена на устройствах Nexus начиная с Galaxy Nexus с прошивкой Android 4.0.4. Как ни странно, но другие андроид смартфоны не имеют данной уязвимости, проблема лишь в стоковой версии лаунчера Google. Надеемся, что теперь софтверный гигант Google обратит на данный факт внимание и выпустит hotfix. А пока, Богдан готов предложить сообществу приложение Class0Firewall из Google Play, которое полностью отключает Flash СМС.

Источник: lg-rus.com

Читайте также  В Челябинской области вынесли приговор матери задохнувшегося во сне младенца
FarmLand